Syncronisations Problem mit Arduino SW

Hilfe und Fragen auf Deutsch
Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Syncronisations Problem mit Arduino SW

Post by Metz » Sun 4. Sep 2011, 22:14

Servus,

ich hab nen recht bekannten Fehler wenn ich einen Datenstand aufs Arduino oder Seeeduino aufspielen mag.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

In beiden Fällen ist die Meldung gleich.
Einen Standard Datenstaz auf das Arduino oder die Seeeduino SW aufs Seeeduino.
auch ist es egal ob es sich dabei ums Arduino 0018 oder 0022 handelt.

Der aktuellste FTDI Treiber ist drauf.

Das Problem hat nicht alleine mit dem Arduino zu tun sondern ist eigentlich nur das Resultat eines schleichenden Ausfalls diverser "COM" Ports an meinem Notebook.
So kann ich zb keine SD Karten mehr am Slot lesen (Hab mir daher schon n SD2USB Adapter gekauft mit dem alles sauber läuft)
Das MUI funktionierte schon länger nicht mehr, aber ich konnte die Software noch über die Arduino SW aufspielen und die Daten übern Serial Monitor rattern sehn.

Ich hätte jetzt gern Windows einfach neu aufgespielt, bekomme dort aber die Fehlermeldung avhuzmu8.sys (Google findet nichts darüber)
Ich hab das Troubleshooting von arduino.cc schon durch und bin die paar schritte durchgegangen, aber nichts half.

Hat jemand vlt schonmal solch nen Ausfall an nem Rechner erlebt?

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Mon 5. Sep 2011, 00:16

Ich bekomm auch die selbe Meldung wenn ich die hex von Dom aufspielen mag...

C:\arduino-0018\hardware\tools\avr\bin>avrdude.exe -p m328p -cstk500v1 -P COM1 -
b57600 -U flash:w:multidisplay.hex:a
avrdude.exe: stk500_getsync(): not in sync: resp=0x00
avrdude.exe: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude.exe done. Thank you.


Was genau hakt da? :cry:

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Mon 5. Sep 2011, 09:40

So, habs jetzt noch an nem andern Notebook mit dem Duemilanove sowie dem Seeeduino Mega versucht.

Installiert wurde Arduino-0022,
mit der LCD4lib.rar von Steff aus m Forum,
dazu wurden die zwei Dateien ( viewtopic.php?p=83#p83 ) ersetzt.
Der Treiber ist von FTDI und nennt sich VCP http://www.ftdichip.com/Drivers/VCP.htm

Softwareseitig muss doch alles passen?
Kann mich nicht erinnern noch anderes Installiert zu haben?
Die Com Ports und Einstellungen passen Augenscheinlich.
Board und Port wurden korrekt ausgewählt.

Installieren wollt ich zum Testen n Example aus der Software. Bekomme immer die oben genannte Fehlermeldung.

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Ich blicks nicht mehr...

OS ist XP SP3.

User avatar
bofh
Posts: 622
Joined: Tue 1. Jun 2010, 19:01
Location: Saarland
Contact:

Re: Syncronisations Problem mit Arduino SW

Post by bofh » Mon 5. Sep 2011, 11:11

ab und zu hab ich auch diese Probs.
Hat nix mit dem Com Port zu tun, das tritt bei mir manchmal auf verschiedenen Rechnern auf. hatte ich auch schon unter Windows und Linux.

bei mir hilfts wenn ich den Arduino am Button manuell resette während avrdude aufgerufen wird

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Tue 6. Sep 2011, 13:30

hmm bei zieht sich das jetzt seit zwei oder 3 Wochen durch.
Geht auch mit M Seeduino Mega nicht.
Wie geschrieben an zwei Rechnern getestet, da ich mit AK47 mal n paar Dateien umgeschrieben habe damit ich die hex flashen konnte.
Auf m andern PC is aber wie geschrieben alles neu an Software. Da gibts keine verstümmelten Dateien ect.

Bin dermasen planlos unterwegs...

User avatar
designer2k2
Administrator
Posts: 712
Joined: Mon 31. May 2010, 20:13
Location: Innsbruck
Contact:

Re: Syncronisations Problem mit Arduino SW

Post by designer2k2 » Tue 6. Sep 2011, 19:15

sehr komisch, hab jetzt sicher 1000x den Code runtergeschrieben auf verschiedenste Arduinos aber das Prob kenn ich nicht :(

Mit nur dem Arduino am USB kannst zb das "Blinken" Beispiel auch nicht hochladen?
itsmyfault...

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Tue 6. Sep 2011, 19:44

nein. hab alle examples durch.

Java wurde Aktuallisiert.

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Tue 6. Sep 2011, 23:09

Gibt nen Commandozeilenbefehl mit dem ich die COM Ports ansprechen kann?
So wie zb ne IP im WEB oder Netzwerk?

Metz
Posts: 393
Joined: Tue 1. Jun 2010, 18:12

Re: Syncronisations Problem mit Arduino SW

Post by Metz » Wed 7. Sep 2011, 06:16

Servus, das Seeeduino lässt sich jetzt Flashen.

Der Jumper für den Reset musste auf Automatisch gestellt werden.

Das Arduino Duemil...werkelt noch nicht, aber bei dem bin ich mir eh nicht mehr sicher obs werkelt. Auch egal, da ich für mich auch n Seeeduino Mega kaufe.

Jetzt hab ich das Problem das ich nur Balken auf m Display angezeigt bekomme.
Über die Arduino IDE (22) und das Mui seh ich aber Daten reinkommen.

Auch das Flashen der normalen Multidisplay.hex klappt laut Consolenfenster.
Die wird am seeeduino wohl nicht werkeln, aber ich sollt was auf m Display sehn?
Wie is es bei der Hex? Da sollt ich über die MUI doch auch n eingang sehn? (Aber wie gesagt, eigentlich die falsche hex für mich?)

bofh, hast mir da evt eine? Ich mag dran erinnern das ich der mit der Langen Leitung bin. Kabel mit 1,5m was zu Problemen mit der Anzeige geführt hat.

Danke euch auf jedenfall fürs reinschaun.
Hoffe das der Fehler damit bei anderen auch gelöst werden kann, sofern s haben.

User avatar
bofh
Posts: 622
Joined: Tue 1. Jun 2010, 19:01
Location: Saarland
Contact:

Re: Syncronisations Problem mit Arduino SW

Post by bofh » Wed 7. Sep 2011, 10:37

ja, für den Mega brauch man natürlich ein anderes Hex File.
probier das im Anhang mal aus
Attachments
mega-v1-test.zip
seeduino mega für v1 test
(34.19 KiB) Downloaded 195 times

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest