[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 580: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/session.php on line 636: sizeof(): Parameter must be an array or an object that implements Countable
MDForum • Metzes Problem Thread - Page 2
Page 2 of 4

Re: Metzes Problem Thread

Posted: Tue 8. Nov 2011, 10:53
by designer2k2
da gibts ja eigentlich nur die Pinbelegung die unterschiedlich ist, die stimmt?

Re: Metzes Problem Thread

Posted: Tue 8. Nov 2011, 15:57
by Metz
Image

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 04:25
by designer2k2
das schaut mal richtig aus!

Was genau macht das LCD, kommt die Hintergrundbeleuchtung? komplett Schwarz? blöde Zeichen? :?:

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 06:25
by Metz
Schwarz, je nach Kontrast, 2 Balken.

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 09:04
by designer2k2
2 Balken heißt das Init schlägt fehl, also das LCD wird nicht richtig initialisiert (für 4 Zeilen und 4 Bit Modus)

Hast du die nicht belegten Pins am LCD auf GND gelegt oder Offen? Besser ist auf GND gezogen, aber offen "sollte" nichts machen :oops:

dreh mal in der LCD4Bit.cpp in der void LCD4Bit::init () (Um Zeile 157) die ganzen Delays um ca 10% oder 20% hoch.
Das könnte helfen...

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 16:53
by Metz
Sind Offen.

Hat nichts gebracht. :(

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 18:57
by designer2k2
Hast ein Oszi? Wenn ja, mal im Betrieb alle Leitungen zum LCD anschauen, da muss es hektisch zugehen und saubere 0-5V Flanken geben.
Sonst, LED mit Vorwiderstand an die Pins halten, die muss flackern auf allen Leitugen.

Idee ist zu prüfen ob ein Ausgang vom Mega tot ist :roll:

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 19:27
by Metz
Das mit der LED kann ich machen. Oszi hab ich ned.
Ich will aber noch erwähnen, für n fall das des unterging, das ich ZWEI Seeeduino Mega hier hab.
Eines davon ist nagelneu.
Und auf beiden läuft die hex von Dominik sauber durch.

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 19:40
by Metz
Hab jetzt die LED dran:

Auf allen Leitungen (Angeschlossenen) ist "Saft".
Aber es blinkt nix, es leuchtet Dauerhaft.

Re: Metzes Problem Thread

Posted: Wed 9. Nov 2011, 19:48
by Metz
Mit der Hex von Dom flackert es auf (Fast) jeder Leitung schön schnell aber gleichmäsig.
Auf 4 Pins is nur n Leuchten. Wobei ich mir einbilde das es ganz schwach flackert. Kann ich aber nicht zu 100% sagen. Fakt ist andere Flackern deutlicher.