Page 1 of 1

[SOLVED] Empty data table in UI

Posted: Thu 13. Nov 2014, 20:48
by erikiiofph7
I can't get data logging to work. The PC is connected to MD with the usb cable, and they do have a connection since clicking the "A hold" button has effect. But the table in the tab Data is empty, and the Visualization tab does not have any curves, just a en empty plot area.

Do you need to do something more to start acquiring data?

The MD runs code compiled from SVN.
The laptop runs the bofh-compiled UI on windows 8. UI version mUIv2-setup-2.0-beta10.0-release-x86-df32

EDIT: problem is solved

Re: Empty data table in UI

Posted: Tue 18. Nov 2014, 00:30
by bofh
seems like a protocol mismatch

how old is your compiled avr firmware from svn (from trunk/eclipse/multidisplay)?

Re: Empty data table in UI

Posted: Wed 19. Nov 2014, 20:47
by erikiiofph7
It's revision r916, which seems to be committed Oct 21.

Re: Empty data table in UI

Posted: Mon 24. Nov 2014, 15:17
by bofh
Thats new enough. You are using eclipse to build it?

Re: Empty data table in UI

Posted: Mon 24. Nov 2014, 23:25
by erikiiofph7
Oops, it appears I missed the data sent over serial when I configured my MultidisplayDefines. The thing is that to get MD configured for my engine I created a new set of defines instead of using MultidisplayDefinesDigifant.h/MultidisplayDefinesDigifant.h. My new file is based on one of them though. The problem was that I missed to add my engine to this if statement in line 1527 in MultidisplayController.cpp (where the VR6 is mentioned):

Code: Select all

#if defined(MULTIDISPLAY_V2) && defined(VR6_MOTRONIC)
		// 35 bytes
		outbuf = 0;
		for ( uint8_t i = 0; i < 35 ; i++ )
			Serial.write ( (uint8_t*) &(outbuf), sizeof(uint8_t) );
With my engine added to the if statement, it now sends the 35 bytes of empty data to match the expected pattern. Which means I now get data into the table & plot on my computer.

Thanks for the help!

Re: [SOLVED] Empty data table in UI

Posted: Mon 24. Nov 2014, 23:44
by bofh